Jump to content
Sign in to follow this  
aspekt

AE error : ram preview needs 2 or more frames to playback

Recommended Posts

I havnt been able to get around this all day. I've gotten it plenty of times and usually a restart of the program solves it. i've certainly selected more than 2 frames for previewing. Anyone have any insights to this??

Share this post


Link to post
Share on other sites

Could be that AE has run out of RAM and has no room left for a RAM preview?

 

Have you tried "purging" the memory? (Edit->Purge->All)

 

I'd also be interested to know what your Memory & Cache settings are along with your setup.

Share this post


Link to post
Share on other sites
Could be that AE has run out of RAM and has no room left for a RAM preview?

 

Have you tried "purging" the memory? (Edit->Purge->All)

 

I'd also be interested to know what your Memory & Cache settings are along with your setup.

 

well i keep the memory & cache setting set to the default. nucleo pro reccomends that. this is happening right when i start the program though no real ram expenditures

Share this post


Link to post
Share on other sites

I wish I had a copy of Nucleo Pro... :)

 

My guess is that it probably has something to do with Nucleo, though. Did you recently change setups or upgrade? Is it an intermittent problem or did it all of a sudden just start causing you problems overall or just with a specific file?

 

EDIT: To test this, try moving Nucleo outside of the AE plugins folder temporarily, restart AE, and try a regular RAM preview. If this alleviates the problem, then I would be almost positive it would have something to do with Nucleo.

Edited by JonAndesign

Share this post


Link to post
Share on other sites

What's your set up? I get this all the time and it is a memory caching problem. It seems to be worst on 7.0 running on MacTel boxes, but I've gotten it on PPC systems as well.

 

Basically it seems that AE 7 doesn't release its cache data properly. This can lead to "stuck frames" in your RAM preview (frames from a prior preview that won't seem to go away). It can also lead to a weird message that I can't remember exactly but says something like 0k available for uTracker or something. Or the error you're getting. I've found a few solutions:

 

1. quit and restart AE

2. restart computer

3. AE 7 seems to run more stable if the memory and cache preferences are 1.5GB or below. On most systems this means reducing both to around 50%.

 

CS3 has cleared up the problem for me.

Share this post


Link to post
Share on other sites
I wish I had a copy of Nucleo Pro... :)

 

My guess is that it probably has something to do with Nucleo, though. Did you recently change setups or upgrade? Is it an intermittent problem or did it all of a sudden just start causing you problems overall or just with a specific file?

 

yeah, i dissabled nucleo pro before thinking the same thing but it wasn't the culprit. even tried to do a fast preview w/ nucleo pro & it crapped out...It's happend before like i said every now & agin on a heavy preview, but never like this. & this is just animated text in 3D space nothing too intensive. no filters, or heavy images...I'm at a loss for words with this.

 

I also tried moving the playback head, nothing. I'm on a dual xeon 3.0 4 gigs ram 4TB storage. running CS3

Edited by aspekt

Share this post


Link to post
Share on other sites

Man, that is really weird.

 

Is your computer recognizing all of the installed RAM? I have the exact same setup (with only 1.5TB of storage), and I've never had that problem (I'm running OSX, you might be running windoze). So weird... I am at a loss too.

 

Does the problem happen when you drop the preview resolution down to half & quarter?

Share this post


Link to post
Share on other sites
Man, that is really weird.

 

Is your computer recognizing all of the installed RAM? I have the exact same setup (with only 1.5TB of storage), and I've never had that problem (I'm running OSX, you might be running windoze). So weird... I am at a loss too.

 

Does the problem happen when you drop the preview resolution down to half & quarter?

 

 

yeah man i did a custom res of 12x12 & it still did it. I'm on windows not an intelmac.

Share this post


Link to post
Share on other sites

Unfortunately I have no idea where the PC preference file is located, but that would be my next step in your situation.

 

The apple pref file is named "com.Adobe.After Effects.8.0.plist" if it helps at all.

 

EDIT: Also saw "Clean Database & Cache" in Memory & Cache settings. Never had to use this before, but its worth a click!

Edited by JonAndesign

Share this post


Link to post
Share on other sites
Unfortunately I have no idea where the PC preference file is located, but that would be my next step in your situation.

 

The apple pref file is named "com.Adobe.After Effects.8.0.plist" if it helps at all.

 

EDIT: Also saw "Clean Database & Cache" in Memory & Cache settings. Never had to use this before, but its worth a click!

 

hey thanks for your help with this. really appreciate it. I found the pref's and there were 3 pref's files...kinda wierd...anyway trashed them & things are good to go!!

Share this post


Link to post
Share on other sites
humm.. this happens to me after I use trapcode soundkeys.

a purge all usually does it though.

I'm having the same problem using particular. When using multiprocessing on my Intel Macpro with 16 gigs or RAM, it errors and says can't render multiple frames simultaneously. If I turn off Multiprocessing it gives me the error everyone is talking about. I need to preview this and it's starting to frustrate me. I've done all of the suggestions above and I have the same result no matter what. Please Help!

Share this post


Link to post
Share on other sites
I'm having the same problem using particular. When using multiprocessing on my Intel Macpro with 16 gigs or RAM, it errors and says can't render multiple frames simultaneously. If I turn off Multiprocessing it gives me the error everyone is talking about. I need to preview this and it's starting to frustrate me. I've done all of the suggestions above and I have the same result no matter what. Please Help!

 

In my case, I've narrowed this down to using Particular on a layer with the inpoint trimmed beyond the default inpoint, cause it to use some sort of time remapping voodoo, which I don't think Particular likes.

Share this post


Link to post
Share on other sites
In my case, I've narrowed this down to using Particular on a layer with the inpoint trimmed beyond the default inpoint, cause it to use some sort of time remapping voodoo, which I don't think Particular likes.

 

Oh! You just fixed my 2 hour headache... I have a really deep comp and couldn't trace where the error was coming from! Thanks so much! :rolleyes:

Share this post


Link to post
Share on other sites

I know this is probably really obvious, but I sometimes get this when I accidentally hit "b" or "n" and set my work area to just one frame. It doesn't happen often enough for me to notice it, so it always makes me go...wtf? Sounds like your issue is a bug, just thought that I'd put this in the mix for people who have never seen this error before.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...