Jump to content
Sign in to follow this  
theta

plugin/technique to smooth out stuff...

Recommended Posts

So lets say I had a thin line that is really jagged, like the top of some mountain peaks. I want to smooth it and average it out so it looks more like rolling hills. Any ideas?

Share this post


Link to post
Share on other sites
So lets say I had a thin line that is really jagged, like the top of some mountain peaks. I want to smooth it and average it out so it looks more like rolling hills. Any ideas?

 

Draw a smoother line? Simplest solution I can think of. If it's just a simple line.

Share this post


Link to post
Share on other sites
Draw a smoother line? Simplest solution I can think of. If it's just a simple line.

 

Well the line is really a particle system coming from 3d. Can't really smooth out the interpolation of it in 3d, so I was hoping there'd be a way in AE.

Share this post


Link to post
Share on other sites
Well the line is really a particle system coming from 3d. Can't really smooth out the interpolation of it in 3d, so I was hoping there'd be a way in AE.

 

Are you trying to save render time in 3d by fixing it in post? Because the easiest way would be to do it in 3d. If the dynamics tools won't do what you want, there are plenty of ways to make a smooth line in most 3d software.

Share this post


Link to post
Share on other sites
Are you trying to save render time in 3d by fixing it in post? Because the easiest way would be to do it in 3d. If the dynamics tools won't do what you want, there are plenty of ways to make a smooth line in most 3d software.

 

Well it's not just a simple line in 3d. It's a particle system creating a line. The emitter is being driven by an audio controller. So the line of particles are synching up to a voice, creating a waveform. However, the line it creates is too jagged, I've tried a lot of different things in 3d, and I've gotten it a lot smoother, but not smooth enough.

 

I need it to be a particle system, because at one point in the dialogue, the particles take on their own shape and float off screen.

Share this post


Link to post
Share on other sites

Ok- two things:

Have you tried adjusting the audio source that is driving the particles? Maybe an EQ or volume levels adjustment will create less jagged lines.

 

also- why not use the particles only when you need them- when they take their own shape and float off screen. You could animate your line, with some kind of displacement driven by the audio, and switch it for the particles with a short transition right before they float off.

Share this post


Link to post
Share on other sites

I've tried adjusting the audio, including doubling the length so that the waveform is more spread out over time. Didn't work. I've adjusted some settings to get it a lot better than it was initially, I just need to smooth it out a little more. I have a combination of dummy objects and a postion contraint to kind of average out the audio waveform in 3d space.

 

I'm not going to use a line and then switch to particles right before the particle motion takes over. I've got a nice motion already worked out with the particles, I just need to smooth them out a bit. Plus that will take more time to setup and I'll have to worry about making the switch seamless. Not to mention the client's already seen and approved the look of this, (with exception of the jagged lines) I don't want to just completely change workflows this late in the game.

Share this post


Link to post
Share on other sites

I think I've found something that might work.

 

Image Lounge: Border Patrol. Replace the line render with this and turn Edge Smoothing all the way up to 32. I wish I could go higher than 32 though. Although, this seems to be working pretty good for the moment.

Share this post


Link to post
Share on other sites

just FYI - not sure which package you're working in - but you should be able to throw a median operation between the audio and the particles in order to smooth it out.

 

Border patrol is an oldie but goodie. I use it to pull blend mattes for compositing all the time.

Share this post


Link to post
Share on other sites

It sounds like it may be the frame rate that limits the plugin from creating a smoother line. Try making a comp with lets say... 200FPS and apply the same technique. THEN, bring that comp in your main comp. This should allow the plugin to create a smoother line because there is more temporal resolution.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...