Jump to content
Sign in to follow this  
coldwarx

C4D: Sky/Luminance light still seen after unchecking 'Seen By Camera'

Recommended Posts

Hey everyone,

I'm creating a little town inside a snowglobe. I put on a Sky (light?) and applied a HDR image to the luminance channel. Then I threw on a compositing tag and unchecked, Seen By Camera. Outside of the globe, it's all empty (alpha). But inside the globe, the sky can be seen... What can i do about it?

 

I'm attaching an image. See the horizon that seems perfectly flat inside the globe? I don't want it there... Or i do want it there but i want it to change angles when the camera changes angles.

globetest_sky0000.jpg

Edited by coldwarx

Share this post


Link to post
Share on other sites

you could try turning of seen by reflection and rays. I think your issue is more of a transparency issue, i have seen C4d handle transparency badly which looks like what is happening. can't remember how to fix it though. you may have to check compositing bkg.

Share this post


Link to post
Share on other sites

im no expert in c4d so i don't know if this will help, but i was watching a greyscalegorilla tutorial on materials, and he mentioned turning up the refraction just slightly in the transparency channel(he went from 1>1.2). i think its supposed to help bend the transparency to the shape, if thats what you're looking to do.

Share this post


Link to post
Share on other sites

You can turn off the seen by refractions and seen by transparency checkboxes in c4d. That'll solve your problem.

Then you'll only get reflections of your sky.

 

thank you... that's exactly what i needed to do!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...