Jump to content
Sign in to follow this  
ciaran

Change RAM allocation in C4D?

Recommended Posts

I'm new to Cinema 4D and have run into a major problem with rendering out a basic 150 frame, HD animation consisting of text in a sweep nurbs, a cube, cylinder, torus, plane & sky (has HDRI map) with an animated camera. The materials have fresnel reflections and I'm using global illumination, so I'm expecting long render times. The thing is that the first half of the animation was rendering a frame every 5 minutes or so, but then suddenly cranked up to 3 hours a frame. I've sinced doubled my RAM and the renders are now taking 6 hours per frame, without any notable change in the scene.

 

I've set the GI rendering as camera animation, turned down many of the IR settings to low, anti aliasing set to best/animation, no motion blur, cache shadow maps, set the Picture Viewer ram usage to 10Gb, etc., yet in the task manager, it says C4D 64bit is only using 1Gb of RAM, with 3Gb in use by the PC overall and that there's 9Gb available.

 

Is it possible to change the allocation of RAM to C4D as you would in After Effects? Anything else I can do to render faster?

 

Running c4D 11.5, Win 7, i7 2.66Hz processor, 12Gb RAM, Nvidia Geforce 7900 GS graphics card.

Share this post


Link to post
Share on other sites

adding more ram is not going to speed up your render...it will help you handle more data in the scene...but the only thing that will speed up your render is more cpu power and scene/material optimization.

maybe try posting some shots of your settings or materials...something like that.

Share this post


Link to post
Share on other sites

the only thing i can think of is you might have some process kicking in in the background. Otherwise if your scene remains constent i don't see what could cause this.

 

try rendering it out without Gi and see what the difference is in render times for the frames in question.

 

but best solution is post the file up and let us have a look at it.

Share this post


Link to post
Share on other sites

GI and reflections can take a long time to render, especially if you're using bump maps as well. As vozzz and tarzan_jesus have said, boosting your RAM will have little effect on your render speeds unless you have ludicrously complicated scenes.

 

Check your ray depth settings in the [render settings] > [options] tab, if this is too high your scene will crawl regardless of specs.

 

Dan

Share this post


Link to post
Share on other sites

Thanks for the replies folks. Bit annoyed about the RAM issue, shit happens.... dan_hin, I'm rendering it out with GI and there is a big difference without it in terms of render time. The ray depth settings are at 15 - haven't changed it, so I assume that's the default...

 

For anybody who feels like having a look at the file, it's at http://www.ciaranoconnor.com/downloads/tv-icon+name-v3.zip . Cheers!

Edited by ciaran

Share this post


Link to post
Share on other sites

its your floor material. it has 25% bluriness. That makes everything render really slow. c4d's native render can't do blurry reflections at reasonable speeds.

Edited by vozzz

Share this post


Link to post
Share on other sites

I totally did that on the first few projects I did in Cinema. "15 minute to render one frame? Gee, that seems really long. But hey, that's 3D for you..." I thought to myself.

 

Foolish me. I didn't catch on to the blurriness thing until a few very long weeks later.

Share this post


Link to post
Share on other sites

I haven't looked at the file yet...but blurriness can be usable...you just need to watch the settings...set min samples to 1...max to 60...accuracy to 0%-5%

from there you can start adjusting your settings to taste. also you could always take these rough results and apply a little blur in AE to smooth things out a bit more.

the settings that will change render times the most will be the min samples and the accuracy.

Edited by tarzan_jesus

Share this post


Link to post
Share on other sites

Vozzz and Mousel, thanks for the pointers, I think it worked... Turned the blur off on the floor plane, made a couple of other minor modifications and it rendered in a respectable time. Wierd that the image rendered in the viewport looks different to the final finished render, specfically the floor which looks overexposed... No doubt there'll be more wailing and gnashing of teeth to be done in the future.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...