Jump to content
Sign in to follow this  
vector meldrew

Maya to Cinema 4D via FBX

Recommended Posts

Lately i've spent the past few weeks trying to solve a problem which i would've thought (although quite hard) was definetly possible. i have googled the shit out of it, contacted Maxon, contacted Maya. Got help from all sorts of areas (although none of which are that experience in the cinema 4d side) and still i've made no progress.

 

What i have: is an animated Character rig inside of Maya. The rig is quite complex so i don't expect to get everything over, instead i have gone about using the mesh and then Geocaching the data within Maya (so all i have is animated geometry with no bones etc)

 

What i need: To export the animated geometry from Maya to Cinema 4D (i guess through FBX is my best bet)

 

What happens: Cinema 4D recognizes the file and the geometry and the fact it has animation, however it only brings in the geometry without the animation.

I downloaded FBX quicktime viewer ( very useful - http://usa.autodesk.com/adsk/servlet/pc/item?siteID=123112&id=10775855) so that i could check all my fbx files before importing. However they seem fine. I also did a test and tried importing into 3DS Max - no joy either... same as C4D

 

So i am wondering if anyone here has made this work and could offer any insight. I had read a similar topic of this forum making it sound really easy, however i tried ... and it's not...

 

Maxon told me it should definetly be possible and is most likely some certain option i am missing in Maya... I guess this is the most reasonable conclusion. |

 

 

thanks in advance !

Share this post


Link to post
Share on other sites

What versions of Maya and C4D are you using? No idea if any of this will work but off the top of my head:

 

-Try a super simple scene with a poly cube animating to see if you can FBX that in first. (usually try to divide and conquer to see where the problem lies.)

-Try using C4D in 32bit mode? (I remember having some issue with importing FBX camera animation in 64bit a while back. On Mac in Finder Get Info on C4D app 'open 32bit' checkbox)

-Delete History?

-Make sure animation/camera is baked in Maya first?

-Maybe try exporting from Maya in legacy FBX format? (in the FBX exporter dialog/FBX File Format try some of those, same with Type:Binary/ASCII

-Do any of those other FBX exporters bring animation? DFX_FBX and DAE_FBX?

Edited by superegophobia

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...