Jump to content
Sign in to follow this  
ChrisC

AE CS5 render time massively quicker after restart

Recommended Posts

Anyone had any experience of this? I've found I'm having to restart my Mac every time I want to render anything out of AE, otherwise the render times start to balloon exponentially. I finally gave up this morning after waiting 45minutes to render a comp, aborted about a third in and restarted the Mac, then rendered again and the whole thing finished in 12 minutes.

 

The progress of the render prior to restarting seemed to grind to a halt, all processors start OK but end up sitting idle, spitting out the odd frame when they felt like it, RAM usage sitting at around 18% (of 16Gb). I've got multi-processors enabled and have checked for zombie AE render instances, but there's the right number, and they're all (barely) active - they just aren't working on anything.

 

Then I restart and everything flies again... for a bit... then I have to restart again. and again. Purging doesn't seem to have any effect, neither does cleaning up the cache. In the old days I'd have put it down to memory fragmentation, but that's a thing of the past isn't it?

 

I've got multiprocessors enabled, 2Gb per core. 16Gb total, using OSX10.6.4. No other apps running while rendering. Cheers for any advice - C

Edited by ChrisC

Share this post


Link to post
Share on other sites

Chris,

 

We had a lot of the same problems here. Multiprocessing only seems to be efficient when rendering to image sequences, rendering to quicktime formats like Animation and PNG seems to fill the RAM up rapidly. This causes the render to start quickly then begin chunging along after so many frames, almost grinding to a halt it seems at times. We've found it far more predictable to turn MP off when rendering to quicktime files.

 

Our systems are running Windows 7, 12cores(24threads) and 24GB RAM. So the machines are no slouches, but getting consistent results when rendering hasn't been easy. Out of curiousity what are you rendering too? Video file or Image sequence?

Share this post


Link to post
Share on other sites

We had a lot of the same problems here. Multiprocessing only seems to be efficient when rendering to image sequences, rendering to quicktime formats like Animation and PNG seems to fill the RAM up rapidly.

 

That's interesting, might be the issue. I'm rendering quicktimes @ 1920 x 1120. 32-bit comp. Just tried an image sequence (PNG), and it seems rather slow though, so that might not be it. Here's the processor action, there's a lot of gaps when there's nothing obvious happening.

 

firing-NOT.jpg

 

This is what I get in the rare cases where AE is firing on all cylinders:

 

firing.jpg

 

So, not conclusive, but certainly worth trying. Cheers for the response - C

Edited by ChrisC

Share this post


Link to post
Share on other sites

Anyone had any experience of this? I've found I'm having to restart my Mac every time I want to render anything out of AE, otherwise the render times start to balloon exponentially. I finally gave up this morning after waiting 45minutes to render a comp, aborted about a third in and restarted the Mac, then rendered again and the whole thing finished in 12 minutes.

 

The progress of the render prior to restarting seemed to grind to a halt, all processors start OK but end up sitting idle, spitting out the odd frame when they felt like it, RAM usage sitting at around 18% (of 16Gb). I've got multi-processors enabled and have checked for zombie AE render instances, but there's the right number, and they're all (barely) active - they just aren't working on anything.

 

Then I restart and everything flies again... for a bit... then I have to restart again. and again. Purging doesn't seem to have any effect, neither does cleaning up the cache. In the old days I'd have put it down to memory fragmentation, but that's a thing of the past isn't it?

 

I've got multiprocessors enabled, 2Gb per core. 16Gb total, using OSX10.6.4. No other apps running while rendering. Cheers for any advice - C

 

Hi Chris,as far as I'm concerned, when mp enabled, 2 gb per core you need to have much more than 16 gigs,though it seems a lot...

 

Best advise probably is disabling mp,but there's also a "secret" option you can try.It might be the codec that is hogging RAM,so if you enable "Purge every 20 frames during Make Movie" you will probably get around the problem.

 

You can do this in the Secret preferences by holding down the Shift key and then select Preferences... from the menu. In the Preferences dialog box you can then choose the "Secret" option that will give you hidden features (they are hidden since they will cause AE to render more slowly.)

Don't enable the other checkboxes, just write "20" in the text field. This would do.

 

 

Hope this helped,buddy!

Share this post


Link to post
Share on other sites

Hey thanks darkroomfx - and you used your first post on li'l old me B)

 

I'd forgotten about the purge option, that could help I'll give it a go when AE starts seizing up on me and see how I get on.

 

Know what you mean about RAM - trouble is I've got 8 sticks with 2Gb each, so I'd have to throw out 16Gb and start from scratch to go higher, which wouldn't be cheap... with 2Gb per core though I should get 5 cores when rendering - whereas at the moment I'm lucky to get one, unless I restart whereupon they're all magically back again.

 

I've noticed my console is rammed full with pages & pages of these messages:

 

Sep 24 15:58:17 chris-cousinss-mac-pro aeselflink[1022]: *** __NSAutoreleaseNoPool(): Object 0x133ca0060 of class NSCFArray autoreleased with no pool in place - just leaking

 

which suggests a memory error perhaps? There's a few plug-ins I'm using on this project, I guess they could be the culprit too. Hmmm.

Edited by ChrisC

Share this post


Link to post
Share on other sites

I too have been having this issue. Restarting before any rendering helps my render times a ton. When I've been doing test renders all day my whole computer starts to chug. The purge option has little or no effect.

Share this post


Link to post
Share on other sites

Hi Chris,as far as I'm concerned, when mp enabled, 2 gb per core you need to have much more than 16 gigs,though it seems a lot...

 

Best advise probably is disabling mp,but there's also a "secret" option you can try.It might be the codec that is hogging RAM,so if you enable "Purge every 20 frames during Make Movie" you will probably get around the problem.

 

You can do this in the Secret preferences by holding down the Shift key and then select Preferences... from the menu. In the Preferences dialog box you can then choose the "Secret" option that will give you hidden features (they are hidden since they will cause AE to render more slowly.)

Don't enable the other checkboxes, just write "20" in the text field. This would do.

 

 

Hope this helped,buddy!

 

That's pretty bad ass, thanks for the tip as well

Share this post


Link to post
Share on other sites

I haven't got 64 bit or CS5 but I do know that RAM Preview is slow every time with MP enabled, in fact, I only turn it on before a large render. It would seem that the way memory bundles are parsed by AE causes a backlog and purging (no, I didn't know about the secret prefs either) must address this hogging of memory... has anyone with a clue got anything to add?

Share this post


Link to post
Share on other sites

Oddly enough I experienced something similar to this issue when rendering with C4D R11.5 last week. I had amended a simple animation and was rendering it out when the call came through . . . and a further adjustment was needed. The whole render the first time took around a couple of hours. I made the amend, set the render going and left it for a couple of hours. I came back and noticed after 2 1/2 hours it was only a sixth of the way through. Eventually I stopped the render, rebooted the Mac and started it going again and it rendered in quicker than the first time.

 

So possibly it's not AE but the system that's at fault here.

Share this post


Link to post
Share on other sites

Hi all,

 

I have exactly the same problem... with AE CS4 and mac os 10.6.4.

Never had this issue with CS4 and Mac os 10.5 though, so my guess is it's coming from the system, or something in AE that doesn't agree with Snow Leopard.

 

Edit :

Oh, and my renders are always faster after restarting now, no matter what kind of output (.mov or image sequence).

Edited by J2M

Share this post


Link to post
Share on other sites

Hi

I have the same issue, disabling mp does not help, also tried to give more or less ram reserved for the system.

And I don´t belive plugins are the issue, I´ve had this problem while rendering a single layer keyed comp, using keylight.

 

My guess is some memory problem, it sucks but I give up for now and use cs4 until this is fixed.

I´m on a 2008 octa mac with 16Gb (800Mhz DDR-2) ram btw.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...