Jump to content
Sign in to follow this  
Marnie

C4D: Baking Multiple Rigid Body Cloners?

Recommended Posts

Hi there,

 

Had a look around but couldn't find any posts that answer this question. I have a scene with multiple cloner objects, all with rigid body tags. They all eventually interact with each other. How can I bake the sequence so they all interact properly together? Baking each cloner one at a time screws up all the dynamics and they pass straight through each other. There is also a rotator, attractors, and other rigid body objects in the scene. What is the correct way to cache the calculations for this animation? My graphics card can't keep up, having to calculate every time.

 

Had a look through the help manual and doesn't really mention how to bake multiple objects. Or maybe I'm just being stupid. Any help much appreciated.

 

Thanks!

 

Marnie.

Share this post


Link to post
Share on other sites

Hi there,

 

Had a look around but couldn't find any posts that answer this question. I have a scene with multiple cloner objects, all with rigid body tags. They all eventually interact with each other. How can I bake the sequence so they all interact properly together? Baking each cloner one at a time screws up all the dynamics and they pass straight through each other. There is also a rotator, attractors, and other rigid body objects in the scene. What is the correct way to cache the calculations for this animation? My graphics card can't keep up, having to calculate every time.

 

Had a look through the help manual and doesn't really mention how to bake multiple objects. Or maybe I'm just being stupid. Any help much appreciated.

 

Thanks!

 

Marnie.

 

Man, apply the tag to the clooner, not the objects. Then in the "Collision" tab on the tag, select "Apply tag to children" in the "inherit Tag" option. Then, in the "individual elements" opt, select 2o level, or maybe all, and see if it solves your problem.

Share this post


Link to post
Share on other sites
Man, apply the tag to the clooner, not the objects. Then in the "Collision" tab on the tag, select "Apply tag to children" in the "inherit Tag" option. Then, in the "individual elements" opt, select 2o level, or maybe all, and see if it solves your problem.

 

Hey, yeah have been applying to the cloner. Haven't tried the rest of that so will give it a go, thanks.

 

select all the mograph cache tags and click bake. then they all cache at the same time.

 

Does this work? I seem to remember trying this a while ago on a different project and it didn't work. Is this the way Maxon suggests? Anyways, thanks for the help!

 

Marnie.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...