Jump to content
Sign in to follow this  
shapirog

Can't keyframe particle birthrate in C4D

Recommended Posts

Hi,

It appears that there is no little circle next to birthrate in the settings for a particle emitter in C4D... does anyone have any solution for this?

Thanks,

Gavin

 

 

It could be linked to some user data. You would have to key frame it there. Open up the Xpresso tag and see. If there is nothing being piped into the rate port, then I am not sure. Delete tag and start over?

Share this post


Link to post
Share on other sites

yeah, i don't have that circle either, I remember it used to be avaialable, but it crashed cinema if you keyframed it.

 

simple solution. Add user data slider. and pipe it into birthrate through xpresso

 

watch my xpresso tut at cgtuts if you don't know how to use xpresso

Share this post


Link to post
Share on other sites

I checked R9.6, the oldest install I have, and there is no animation dot

there. So I'm not sure there ever was any.

 

Even if you use an Userdata to drive it it would most likely not do what you

want as the standard Emitter is calculated at the Start Emission frame.

If you change any "non dot" parameter the Emitter re calculates in

an unpredictable manner as far as I can see.

 

 

Cheers

Lennart

Share this post


Link to post
Share on other sites

yeah, Lennart is right, xpressoing isn't a good idea, my bad.

 

and yeah, i checked old version too, and not red dot. Maybe it was a dream? but i definitely remember keyframing stuff on the emitter used to mess stuff up royally on this one project i worked on.

Share this post


Link to post
Share on other sites

I checked R9.6, the oldest install I have, and there is no animation dot

there. So I'm not sure there ever was any.

 

Even if you use an Userdata to drive it it would most likely not do what you

want as the standard Emitter is calculated at the Start Emission frame.

If you change any "non dot" parameter the Emitter re calculates in

an unpredictable manner as far as I can see.

 

 

Cheers

Lennart

 

Oh, my mistake. thought we were talking about TP, and not standard emitters. The dot exists in TP. I never use standard. Sorry for any confusion.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...