Jump to content
Sign in to follow this  
Winston64

Help requested: Edge of compositing bkgrd layer showing in render

Recommended Posts

I'm fairly new to C4D so please excuse the stupidity. But this is driving me insane. The edge of the plane I'm using as a floor/compositing background to catch the shadows of some 3D text keeps showing up in my renders as a thin line.I have a compositing tag on the plane that has "seen by camera" and "compositing background" selected. I have the alpha channel checked in the material for the floor (I'm using a QT in the color channel to match the QT in the Background layer. I have "Frontal" selected).Here is a screenshot of the issue I'm having: http://www.flickr.com/photos/12432732@N04/5392822145/

Not sure how much more info I need to provide in order to help diagnose the problem. Please let me know and I'll post it.

Thanks in advance for any help you guys can provide.

Share this post


Link to post
Share on other sites

Hello'ha,

 

I just did a test and seemed to have everything work. Because my video file is huge i didn't want to bother compressing it and packaging things up but I'll post a pic and let you know my set up.

If you want my scene sans video textures I could do that also.

 

First off I have two materials;

 

BG --> QT put on Luma channel and applied to BG object

 

GROUND --> QT put on a plane but in the colour channel { if on luma it won't accept shadows } but only colour checked, didn't bother with alpha.

 

Added a sky and turned on global Ill.

Added a light to make my object cast shadows and set the density of shadow up to %250 and also set to cast area.

 

Added Composite tag to unsee Sky

Added composite tag to plane and clicked on the composite bg box -- left all other default boxes as is.

 

You're keeping your camera locked off right?

 

zebra.png

Edited by Hamilton

Share this post


Link to post
Share on other sites

My camera is locked off. Unfortunately, I can't upload the project. I created an object buffer around the text and turned off the BG.I combined the GI render, buffer render and my original footage (as the background) in AE and that got rid of the line. But it seems really inefficient.

I will have to try Hamilton's settings and see if that works for this project.

Thanks for the help. And I'll take any other input I can get on this problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...