Jump to content
Sign in to follow this  
&Son

Thinking Particles - PDeflector Issue

Recommended Posts

Hello,

 

I have a "rocket". It needs to fly through a cloud, leaving a hole and scattering about some of the cloud. I am relatively new the Thinking Particles, but I made a set up that should work for my needs. ONLY...its not. The deflector node is looking changing the position of all my particles upon the event. Basically for a few frames my particles jump around then seem to come back together in a different arrangement. The only thing I can assume that could be a factor with this simple set-up is that I have my particles in a matrix object with a random effector generating the random order of clouds, and after it is deflected, it generates a new random seed?

 

Is there a better set-up, or a solution to this problem?

 

Please help...

 

Screen%20shot%202011-03-24%20at%205.51.10%20PM.png

 

Screen%20shot%202011-03-24%20at%205.51.19%20PM.png

Share this post


Link to post
Share on other sites

without a scene file all we can do is guess.

 

before anything else :

did you check out what the Particle Priority (Before Effector / After Effector ) in the Matrix Object does ?

 

d

Edited by douwe

Share this post


Link to post
Share on other sites

There was a similar question on the cineversity forum, the scenefile there incorporated the group change preset which changed

particle groups based on collision between a polygon object and the particles and no deflector. Here's the link to the thread.

http://www.cineversity.com/forum/forum_posts.asp?TID=3112&PN=2

Edited by tezuka

Share this post


Link to post
Share on other sites

nothing's wrong with your tp/mograph setup. all your particles do exactly what you need them to.

it's the pyrocluster that's misbehaving.

 

that's the issue you want to troubleshoot.

 

d

Share this post


Link to post
Share on other sites

nothing's wrong with your tp/mograph setup. all your particles do exactly what you need them to.

it's the pyrocluster that's misbehaving.

 

that's the issue you want to troubleshoot.

 

d

 

Man, thats the standard behavior of the matrix generating tp, once you change its group, the matrix generates new particles. I dont know if there is an way to change or bypass that.

What you can do is use, i think, the getvolumeposition node to get a random position inside a cube to generate the particles. Just generate particles using pstorm conected with the surface to make the particles stay inside de cube.

I think it will do. Dont forget to use a timer node to stop creating particles.

 

I hope it helps!

Share this post


Link to post
Share on other sites

Man, thats the standard behavior of the matrix generating tp, once you change its group, the matrix generates new particles.

@gui :

of course, but the new particles get generated at the old particles' positions.

one particle simply replaces the other.

 

@&Son :

if you're still looking for a solution : your particles are fine, it's your pyrocluster.

the issue is in the settings of your Pyrocluster's Clouds Materials, and it's only a Preview Issue.

Your Matrix generates 7*6*6 = 252 Particles.

In your Clouds' Shape Tabs, your Max. visible Parameters are set to Preview only 100 clouds.

 

raise that number = issue solved, right ?

 

cheers,

douwe

Share this post


Link to post
Share on other sites

 

if you're still looking for a solution : your particles are fine, it's your pyrocluster.

the issue is in the settings of your Pyrocluster's Clouds Materials, and it's only a Preview Issue.

Your Matrix generates 7*6*6 = 252 Particles.

In your Clouds' Shape Tabs, your Max. visible Parameters are set to Preview only 100 clouds.

 

raise that number = issue solved, right ?

 

 

Thanks, douwe. Your a life saver.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...