Jump to content
Sign in to follow this  
Duder

Net Renderer

Recommended Posts

Anyone use Macs and Windows on the same network?

 

Ie, I have a main Mac workstation and 2 x Windows machines (1 is a file server) and would like to use both of the windows machines and also the Mac all together to render frames. I use OS X for all the work. The windows machines are fairly fast, i7 Quads. The windows machines run Windows 7 x64 & Windows 2008 Server

 

What's the easiest way to set it up? Not using any special plugins so it shouldn't be a big issue.

 

Thanks!

Edited by pix3l

Share this post


Link to post
Share on other sites

As long as all the computers are on the same network it should work just fine without having to do anything special. The different OS doesn't matter.

 

If you have different processor types there's a small chance the frames will differ as the processors might work at differing levels of accuracy in floating point calculations. That was a problem before Macs went to Intel chips. Shouldn't be a problem with the modern Macs.

Share this post


Link to post
Share on other sites

Just tried it, seems odd that I need to use a router/switch since the main server needs to connect to all computer with the same IP. I'm gonna go buy switch.

Edited by pix3l

Share this post


Link to post
Share on other sites

I have both Mac and win machines running net render, no issues of which to speak. (Other than my main workstation/master, all other machines here are connected via WiFi. I suppose I could realize better performance with everything hard-wired, but I typically only need NetRender for the computationally intense shots, so file swap becomes less of a bottleneck issue).

 

-mike

Share this post


Link to post
Share on other sites

Thanks Mike.

 

Quick question as I never set up Net Render (but used it on jobs a lot)...

 

I have 1 data server, 2 computers connected via gigabit crossover (so no switch).

 

I was able to successfully get my Mac to communicate with the windows server so I have 2 clients running. Now the third one won't connect. It is also connected via crossover to the data server (which is running the net render client).

 

So the question is, do all the clients need to access the same IP in the server setting? Or is it enough just to see the computers since all the computers have their own private IPs?

 

I should probably get a switch or a router instead of trying to make this work...since all the machines have multiple ethernet ports anyways.

Edited by pix3l

Share this post


Link to post
Share on other sites

Gigabit ports don't need any crossover cables, the have auto mdx.

I agree 100% with firemind, get a switch.

As for setting up netrender, once you have all machines in one ip subnet you just need to start the clients and make sure that they have the correct server IP entered. Double check that the ports are correct, the defaults for the server port on windows and OS X are different (80/8080)

Cheers

Björn

Share this post


Link to post
Share on other sites

So I used a cheap switch between 3 computers (1 OS X SL, 1 Windows 7 and 1 Windows Server 2008 R2). So the server is running on Win2k8 with a client. The server and the net render client are on Win2k8. A client on Win7. A client on OS X.

 

In the client area of the web interface, I see 3 clients.

 

When I send a job in and hit start, all 3 clients start rendering their assigned frames...but the Win2k8 machine (which is also running the server client) stops rendering (I see Stop Rendering at <xxxxxx> in the client) after about 16 frames, only leaving the other 2 clients working (until they end). The win2k8 machine is still visible in the clients list, but it switches to the "waiting" mode.

 

Any ideas? Is it a win2k8 issue? If it was, I would assume that the client would stop working too. I also tried restarting the c4d client on the Win2k8 server. It just establishes a connection, but doesn't start rendering at all. It is in the waiting state under the web interface.

Edited by pix3l

Share this post


Link to post
Share on other sites

This probably won't solve your current problem (although it might).

 

If you're running a Server and Client on the same Windows machine:

Go to the Task Manager, find the C4D Client, right-click and set it's priority to 'lowest'. You'll probably get a Windows warning message...just ignore it.

 

This means when the Server needs CPU time it will always get it instead of possibly waiting for the busy Client to release some resources.

Share this post


Link to post
Share on other sites

Thanks for the reply.

 

Didn't seem to help :(

 

I just want to note that the server and the windows 7 machine have the exact same CPU, memory card, motherboard, RAM modules. It might be a Win2k8 issue?

 

Any ideas Björn? Thank you

Share this post


Link to post
Share on other sites

Yes, i use Win2k8 with several CINEMA 4D installations and it works fine, however you will have to make sure that the security settings don't prevent the applicaiton from doing it's job. The firewall and connectivity settings are much more restrictive for example.

 

Edit: The missing graphics card can have an influence, try to start CINEMA 4D with the commandline option -noopengl

Edited by Srek

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...