Jump to content
Sign in to follow this  
saifsohailkhan

Final Render different than In Cinema 4D

Recommended Posts

This is the render in Cinema 4d but when i render it out using Net-Renderer it comes out different [second image]. I am not sure what i am doing wrong. The main object that is transparent also does not show up in Interactive Render Region at all.

 

Both screens are Frame 61

 

 

c3u3n.jpg

 

 

 

Final Render with NetRenderer

 

2q1gar7.jpg

 

 

I think it has to do something with the Renderer not recognizing the bend deformers and the mesh. Help Please

Edited by saifsohailkhan

Share this post


Link to post
Share on other sites

If i turn off the mesh deformer it appears in the interactive render region but then i lose the bend i had on the object. It renders correctly to desktop if don't use Net-renderer but then I am losing the ability to render in higher quality because my computer is a mac mini.

Share this post


Link to post
Share on other sites

Hi saifsohailkhan,

 

I had a similar problem a while back when using net renderer. I would first check the documentation for net renderer in the help menu and go through some of the trouble shooting issues. The problem i had was with dynamics. It would render out fine from cinema but then everything would go wrong when using net renderer. All i had to do to fix the issue was to make sure that everything in my scene was cached and baked before using net renderer. You might have to do the something similar with your bend & mesh deformers. Also you can try baking your animations into keyframes to see if that will work too. Hopefully that helps.

 

Cheers,

 

Miguel

Share this post


Link to post
Share on other sites

If i turn off the mesh deformer it appears in the interactive render region but then i lose the bend i had on the object. It renders correctly to desktop if don't use Net-renderer but then I am losing the ability to render in higher quality because my computer is a mac mini.

Hi saifsohailkhan,

 

I had a similar problem a while back when using net renderer. I would first check the documentation for net renderer in the help menu and go through some of the trouble shooting issues. The problem i had was with dynamics. It would render out fine from cinema but then everything would go wrong when using net renderer. All i had to do to fix the issue was to make sure that everything in my scene was cached and baked before using net renderer. You might have to do the something similar with your bend & mesh deformers. Also you can try baking your animations into keyframes to see if that will work too. Hopefully that helps.

 

Cheers,

 

Miguel

 

 

I actually am looking for the option for baking to keyframes. Would you know where i could find that option for the deformers?

Edited by saifsohailkhan

Share this post


Link to post
Share on other sites

 

 

I actually am looking for the option for baking to keyframes. Would you know where i could find that option for the deformers?

 

Here is how you can bake it to keyframes. First switch your layout to animation. Then select your object that is being deformed in the timeline. Then go to functions then bake options. Check everything then click ok. I would make a copy of your file to test this.

 

21kkz1i.jpg

k2helg.jpg

4ghxe8.jpg

ixdquf.jpg

Edited by Mr_Eyes

Share this post


Link to post
Share on other sites

 

Here is how you can bake it to keyframes. First switch your layout to animation. Then select your object that is being deformed in the timeline. Then go to functions then bake options. Check everything then click ok. I would make a copy of your file to test this.

 

 

21kkz1i.jpg

k2helg.jpg

4ghxe8.jpg

ixdquf.jpg

 

 

 

I found the bake objects panel but my mesh deformer is not animated only the bend deformers are animated and the options for bake object panel are quite different in R12. When i turn off the mesh the object appears without bend. I will probably render this without baking. is just going to take longer because i can't use net-renderer.

 

Thanks for the help though. :)

Share this post


Link to post
Share on other sites

 

I found the bake objects panel but my mesh deformer is not animated only the bend deformers are animated and the options for bake object panel are quite different in R12. When i turn off the mesh the object appears without bend. I will probably render this without baking. is just going to take longer because i can't use net-renderer.

 

Thanks for the help though. :)

 

Anytime. Weird thing is though I am on R12 Studio as well. I don't have much experience with the mesh deformer, but i noticed the initialize tab which may help you store the state of the mesh since it is not animated. Hopefully after R13 they will make some serious updates to the net renderer cause it is still tricky to work with sometimes. Good luck with your project it looks very interesting so far.

Edited by Mr_Eyes

Share this post


Link to post
Share on other sites

 

Anytime. Weird thing is though I am on R12 Studio as well. I don't have much experience with the mesh deformer, but i noticed the initialize tab which may help you store the state of the mesh since it is not animated. Hopefully after R13 they will make some serious updates to the net renderer cause it is still tricky to work with sometimes. Good luck with your project it looks very interesting so far.

 

I can't wait to play with the physical renderer in R13 because it gives you the ability to set the amount of time spent on each frame the longer you set it the better it looks.

Edited by saifsohailkhan

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...