Jump to content
Sign in to follow this  
Carey

Atom Array + effectors = help?

Recommended Posts

So I have a polyFX effector inside/under a polygonal object so that its polygons are available for deformation by a plain effector. Works grrrrrrrrreat. Then I put that setup inside/under an advanced atom array to turn the polys into splines+vertices. Fascinating, tell me more!

 

I set the plain effector to scale down/move the affected polys, and when I run it over the object, the atom array-generated splines do indeed scale/move, but the generated vertices do not.

 

The setup is really simple, and I've tried finding some hidden checkbox that does the trick, but nothing's working. So I'm wondering if anyone knows why this might be, offhand, or if it's just a limitation of polyFX or the atom array. (Same behavior with either standard atom array and advanced atom array). No help on the web so far.

 

thanks in advance!

 

Edit: I am literally too dumb to figure out how to post an image or a file here.

Edited by Binky

Share this post


Link to post
Share on other sites

You're right.

Seems to be a no go.

 

You can of course always Range Map the Sphere Radius (Vertices) to the Scale Parameter of your Effector to make it scale along.

 

d

Share this post


Link to post
Share on other sites
You can of course always Range Map the Sphere Radius (Vertices) to the Scale Parameter of your Effector to make it scale along.

 

You had me there for a second, but the effector's scale parameter isn't animated. The effector's position is animated and it's forcing its Mograph magic on all of the individual polys to affect each of them in turn. I wanted that to work so bad! :)

Share this post


Link to post
Share on other sites

I see.

 

I had already started typing this second reply, telling you that...

 

"Depending on what you're actually trying to build here, you could maybe create your Atom Array manually.

(2 Cloners in Object Mode, 1 cloning and auto-scaling Cylinders on the Edges of your Polygonal Object, the other one cloning Spheres onto the Vertices)

These clones will move along with whatever your Poly Fx does."

 

But you would bump into the exact same problem.

The Poly Fx works on the Polys only, and the Vertices, being just Points, don't take any scaling into consideration.

 

Now you can use separate Effectors on the "Vertices Cloner " to play with the Scale,

but I can't think of a way to make that Scale behave in relation to what the corresponding Polygon is doing.

 

So I'm out.

hope somebody else is smarter than me.

 

good luck,

d

Share this post


Link to post
Share on other sites

I'm trying to recreate this problem in C4D but I cannot see what it is, so I have no idea what the problem is.

 

You should use Photobucket or similar to post images here, put the image embed code in the wizard that pops up. Better still, put the project file up for us to prod around in (of course removing logos and corporate shiz from the file if its NDA)

 

Tried mograph cache > tracer object?

Share this post


Link to post
Share on other sites
So here's an image and a file, if anyone's still interested. I haven't figured it out.

 

I am interested, but I haven't figured it out. Came kinda close with Lennart's excellent PLA baker - it bakes the PolyFX breakup as PLA animation, then you can apply the vertex objects straight to the baked mesh. The result is here, is that useful?

Share this post


Link to post
Share on other sites

A bit more refined, a new movie here - the only fiddly bit is that you have to disconnect all polys before baking, otherwise the point count changes and the bake fails. Other than that, seems to be working ok.

Share this post


Link to post
Share on other sites
I am interested, but I haven't figured it out. Came kinda close with Lennart's excellent PLA baker - it bakes the PolyFX breakup as PLA animation, then you can apply the vertex objects straight to the baked mesh. The result is here, is that useful?

You, sir, are a high level wizard.

I got the plugin, but haven't figured out how it works yet. My wizardry might not be high enough, but I'll bang away on it.

Thanks, man!

Share this post


Link to post
Share on other sites

You, sir, are a high level wizard.

I got the plugin, but haven't figured out how it works yet. My wizardry might not be high enough, but I'll bang away on it.

Thanks, man!

 

Glad to help sir - I like the look of that still you posted, even with the error it looks foxy. Post back if there's any complications but I'm sure you'll get it working, Lennart's done a great job with PLAmate, it just works...

Edited by ChrisC

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...