Jump to content
Sign in to follow this  
Philipstudios

True multiprocessor rendering C4D 13 on Mac Pro

Recommended Posts

Hello,

 

I have a 12 core Mac Pro and Cinema 4D 13. When I render I see and feel the machine is not giving full access to Cinema 4D to the processors (I can still do a lot of things while rendering and the render takes its time).

 

I have checked with the Activity Monitor what is going on and I seen that the green is not up to the roof as it should.

 

Screen grab Activity Monitor : www.philipstudios.com/signature/question_01.jpg

 

I went into Cinema 4D and went into preferences to see what option do I have.

 

Screen grab Preferences : www.philipstudios.com/signature/question_03.jpg

 

By reading the help it seems I should disable the Adapt Thread Activity (which I did, but it did NOT help the speed in any way).

 

Am I missing something ? How can I convince my Mac or Cinema 4D to used all the processors at true power ?

Edited by Philipstudios

Share this post


Link to post
Share on other sites

I don't use C4d I use Maya, and I have this issue if i've been working in something like after effects all day, and start a render in Maya. The easiest work around is to restart and then render. Usually then my Ram will clear and refresh and then my render will peak. Hope that helps

Share this post


Link to post
Share on other sites

Am I missing something ? How can I convince my Mac or Cinema 4D to used all the processors at true power ?

Your making it too complicated.

By default, Custom number of Render Threads is disabled. You seem to have enabled it and given it the value 12 which is half of the 24 available in a 12 Core MacPro. You may notice that your CPU maxes out at ~1,200%, which is 50% in the activity monitor... coincidence? No.

 

For full power disable Custom threads or set it to 24 and you'll no long be rendering at 50% power.

 

-m

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...