Jump to content
Sign in to follow this  
iline

Physical and Hair Render are not friends

Recommended Posts

Hey all,

 

Is there a good reason why Physical occludes hair? We're rendering a massive job across 4 computers, and we're at the end of the gig and will probably need to farm it out. One 300-frame render is going to take 72 hours after the big switch to Physical (Frischluft wasn't up to snuff IMO). We have a cylinder spline wrapped around a dynamic spline, oh it floats in the wind so niiiiice....then to make the string extra twine-like we have Fur to do the stray strands and hairs coming off the geometry. So far, so stringy.

 

With the need for accurate lens blur, and our depth matte > Frischluft pipeline made obsolete by the fact that neither of us can make FL Depth of Field do anything like a decent camera blur, we switched over to Physical for the lovely in-camera z-blur. Oh, how the render times soared! Last night's render queue is likely to be Tuesday morning's review. Big fun.

 

Much as turning off the Hair Render checkbox has saved a lot of pre-caching time, it's a shame to see those string whiskers go. I was proud of them.

 

If you add the standard Hair Material to say, a plain cube, and apple+R, you'll see a hairy cube. If you switch on Physical, you'll have one hair per vertex. Why this occlusion? I know that the hair is an 8-bit post process, but yet it doesn't make too much sense to allow the option.

 

Are there other Hair options I am missing? The moment you turn on Physical, the Hair Render section is missing most of its options.

 

Thank you lovely peeps. Back to work. It's 30 degrees outside. I could be lying in the long grass with a Pimm's, but no, somebody insisted we use Physical...

Share this post


Link to post
Share on other sites

Maybe make those hairs into actual polys? From the section below it looks like you're heading for a painful afternoon if you try to force the issue:

 

Hair and the Physical Renderer

Even though Hair can be used in conjunction with the Physical Renderer it does, however, bear several disadvantages:

Rendering hair takes much longer

Hair looks slightly different

Hair Multi-Passes are not supported

Artefacting can occur when rendering hair in conjunction with GI Irradiance Cahe Modes. If this occurs, pre-render the cache (one complete render) and lock it with the Lock command.

What’s more, the Hair render settings are reduced. For example, no anti-aliasing settings with regard to hair can be made. This is done by the Physical Renderer’s Sampling settings. The shadow settings are also reduced greatly.

Share this post


Link to post
Share on other sites

Lordy. It's time to flip a coin. I'm an hour from delivery of the animatic anyway and everything is crashy and non-responsive. Life, oh life, liiiiiife

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...