Jump to content
Sign in to follow this  
aspekt

Thinking particles question

Recommended Posts

I'm using a very basic TP rig and. I'm trying to keyframe the shot and for some reason C4D won't let me. I can set a keyframe for a starting value. But it won't let me change that value. when I advance a frame instead of seeing a yellow circle by "shot" I see a circle with a red outline. Has anyone ever run into this?

Share this post


Link to post
Share on other sites

What exactly are you trying to do? Very few parameters in TP can be keyframed since they are evaluated per particle. You will have to define conditions using other TP nodes therefore...

 

Mylenium

Share this post


Link to post
Share on other sites

I think it maybe a little glitch. I've run into something similar. Set another keyframe of the same value after you initial one and then use the timeline/f-curve to change the value.

 

I think it maybe something to do with TP setup refreshing and setting the value back to it's initial value.

Share this post


Link to post
Share on other sites

I think I've run into the same thing, where I set a keyframe, and it either changes back or disappears if its a new keyframe. I have found that while manual keyframing doesn't work, turning on Auto-Keyframing works perfectly. Not sure why, but I'm guessing it's some sort of XPresso glitch or bug.

Share this post


Link to post
Share on other sites

I have the same trouble - been that way since R10 at least. I always just set two identical keyframes at the times I need and then open the f-curves and adjust the values there. Kind of a pain, but it works.

 

R

Share this post


Link to post
Share on other sites

I think I've had the similar issue. If it is the same problem, when I input a number in a input box I "command/CTRL" click on the keyframe dot right away instead of tabbing out of the input box or clicking to another box.

Share this post


Link to post
Share on other sites

It's an unfortunate limitation. Changing the value automatically triggers a refresh which adjusts the value back to the animated value. Either disable the execution of expressions or work with the timeline.

Cheers

Björn

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...