Jump to content
Sign in to follow this  
TommyTronic

Crunchy white outline on alphas? / C4D

Recommended Posts

I wanted to add, that these tentacle looking things are a hair material on a tracer, so I'm guessing because it's hair is the reason it's not rendering with an object buffer... The type is fine, but I need a clean alpha for these hairs.

Share this post


Link to post
Share on other sites

straight alpha always renders crunchy. then when you apply the alpha it should all be nice and smooth.

 

its called "premultiplied" in AE i think.

 

im pretty sure its just a matter of changing the alpha settings in AE.

Share this post


Link to post
Share on other sites

Yes set your input to "straight" alpha mode on import in AE. Normally its used to stop you getting black fringing on your renders - so its essentially a better way to render out, although after effects is good at removing the black fringe if you import as "premultiplied"

Share this post


Link to post
Share on other sites

When it comes to cleaning up edges and removing fringe I've had good luck with the min/max effect in AE. It basically expands and grows edges based on color. That when used in combination with the set channels effect might be able to get you a clean result?

 

EDIT:

Looking again at your image, you have anti-aliasing turned on in C4D right?

Edited by sbmotiondesign

Share this post


Link to post
Share on other sites

straight alpha is correct. Premultiplied can give you problems.

 

I suspect this compositor person you referenced needs to interpret alpha as straight. Then all will be fine.

Share this post


Link to post
Share on other sites

I'm tellin ya, that isn't working... Tried several times. And straight alpha was what I knew was right, but I swear in this case, straight alpha was the one giving me problems. Soon as I checked it off, alpha was fine... I dunno man. Weird.

Share this post


Link to post
Share on other sites

I've had the same problem before. I had guessed that C4D was just screwy and the straight vs. premultiplied settings were reversed or something. If I unchecked straight and then interpreted it as straight in AE it worked just fine. I dunno, maybe there is something I was missing.

Share this post


Link to post
Share on other sites

It appears that you have a "Background" object in your scene with a grad on as a material. I think that's throwing the alpha off in calculating the proper straight matte. Maybe try hiding the background object and see what kind of result you get.

 

Side by side of my experiment: (1st with background object active, 2nd with out)

lcro.png

Share this post


Link to post
Share on other sites
I've had the same problem before. I had guessed that C4D was just screwy and the straight vs. premultiplied settings were reversed or something. If I unchecked straight and then interpreted it as straight in AE it worked just fine. I dunno, maybe there is something I was missing.

 

This happens to me all the time and I use the same workaround, always wondered if there was a proper explanation of what's going on here...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...