Jump to content
Sign in to follow this  
CyanSeaHorse

Particular and DOF

Recommended Posts

Hey all,

I have an annoying issue with trap code particular. I'm relatively new to it but anyway, here goes

 

I have an E3D comp with a very narrow DOF, the objects are right up in front of the camera and I want to rack the focus from further out > in.

 

Whenever the focus distance get's low (where I want it, macro so to speak) , the particles (dust) disappear. I've tried near and far clipping but nothing changes.

 

Here you can see that the particles are visible at 233 pixels, but that focus distance is passed my e3d objects

 

 

7mwxnpf.png

 

Here you can see that the focus distance is where I want it, but the particles are completely invisible.

KPb5dn5.png

 

 

I've tried playing with the Z position of the emitter, the Z radius too but nothing seems to work. I want some particles out of focus and some in focus

 

 

 

Thanks, any help is greatly appreciated!

Share this post


Link to post
Share on other sites

Not sure if there's another issue at play here, but usually it just takes fiddling around with aperture and focus distance. Too high of an aperture can make them disappear..

 

I'd toggle DOF on and off, make sure that's the problem first, then set aperture to 0, and slowly increase it up along with focus distance to see exactly when things go wrong.

 

Also, make sure your emitter is putting them far enough apart to get a big variation between in focus and out of focus(emitter size Z, etc..)

Edited by theta

Share this post


Link to post
Share on other sites

Thanks for the reply & the suggestions however in some cases no matter how low I set the aperture the particles still disappear.

 

It's almost as if achieving a macro look with DOF isn't possible with particular - I don't want to believe it because I'm certain I've seen it done before.

 

Or is it perhaps because I've already animated my Element3D layers and the focus distance is simply too close for the particles to be in focus?

 

I tried now on another composition and set the aperture to 0 but as the focus pulled closer than 125 pixels, the particles simply disappeared.

Share this post


Link to post
Share on other sites

Hi - should be possible, have you tried altering the blur level below 100% in the cam settings?

 

It works, but it does get fiddly at small scales.

 

party_dof.jpg

 

You might want to do it in layers, faking the more extreme blur in the background.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...