Jump to content
Sign in to follow this  
Designosauras

Loft Nurbs and Spline error

Recommended Posts

Hi guys,

 

I've tried googling this but have had no luck, so:

 

I've been supplied a model of a bottle (a .dae file) which I need to animate.

The model is horrible. Super dense, triangulated. Pretty nasty. But usable.

Except for the label which I need to remodel because when rendering the artifacting from the imported mesh is naff.

 

So I isolated the label and created a bunch of splines from the horizontal edges with the intention of lofting a new nice mesh. Good work Dane you're a super duper good designer.

But instead I'm getting this super fucked up spaghetti loft that I'm sure has the sole intention of drowning kittens and is no good for anyone.

 

From what I gathered it's the direction of each of the spline points which I think might have something to do with the normals of the original mesh? I'm not sure.

Has anyone had this problem before?

 

In the URL below is a link to the file and some screengrabs.

 

Cheers!

Dane.

 

https://www.dropbox.com/sh/amqhavfj8calkqe/AADVmink1SVWah8FGv5WRT9Ca?dl=0

Share this post


Link to post
Share on other sites

Your splines are all segmented because not all the points on the mesh are connected (two points occupying same 3d space).

To see what I mean, turn off the loft, select the first spline and go into points mode. Each spline segment has a gradation from start to end point. You will see many but there should only be one that begins and ends at the same point.

 

 

You may already know this (basic stuff) but here it is for the sake of completeness (which a lot of replies are completely lacking):

Optimize the mesh first, then select and edge loop and then use Mesh > Commands... > Edge to Spline

 

You will also want to make sure your splines all start at the same vertical edge and all point sequences are in the same direction to keep things clean.

To set the first point do this: Select a spline, go to points mode, select a single point and right-click > Set first point.

To make sure all spline point sequences are moving in the same direction (such as point B is to the right of point A and point C is to the right of point B ): Select all splines and make sure the gradients are moving in the same direction (I have a custom color scheme but I believe the defaults are blue to white). To change the direction of a spline, select it, change to points mode and right click > reverse sequence.

Edited by sbtread

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...