Jump to content


Photo

modify Clone + Delay effector


  • Please log in to reply
9 replies to this topic

#1 vozzz

vozzz

    Eats, sleeps, drinks MoGraph

  • Members
  • 1,785 posts
  • Gender:Male
  • Location:New York, NY
  • Interests:In Budapest Hungary

Posted 09 February 2012 - 02:58 PM

Any ideas why this isn't working?

if you add position it works fine and the position gets a springy effect.

but the modifying of the clone isnt "springyfied"

:(

http://www.mediafire...dvqq55d9c56eq0u

-Aleksey

 

------------------

Ace5 studios
http://ace5studios.com <-portfolio

http://ace5education.com <-tutorials/blog/facebook page

 

http://plus.google.c...lekseyVoz/posts <- google+ page


#2 Mylenium

Mylenium

    Mograph Deity

  • Members
  • 1,494 posts
  • Location:Leipzig, Germany
  • Interests:cycling, music, Sci-Fi

Posted 09 February 2012 - 03:48 PM

Yes, it only works on transform properties.

Mylenium
[Pour Mylène, ange sur terre]
----------------------------------------------
www.myleniumblog.com

#3 vozzz

vozzz

    Eats, sleeps, drinks MoGraph

  • Members
  • 1,785 posts
  • Gender:Male
  • Location:New York, NY
  • Interests:In Budapest Hungary

Posted 09 February 2012 - 05:28 PM

bummer...

-Aleksey

 

------------------

Ace5 studios
http://ace5studios.com <-portfolio

http://ace5education.com <-tutorials/blog/facebook page

 

http://plus.google.c...lekseyVoz/posts <- google+ page


#4 dan_hin

dan_hin

    MoGraph Demi-god

  • Members
  • 717 posts
  • Gender:Male
  • Location:Nottingham, UK
  • Interests:Skateboarding, sci-fi, mograph

Posted 10 February 2012 - 11:40 AM

Tim Clapham has a way to link the delay effector to parameters other than PSR. I'll see if I can dig out the xpresso setup.

#5 vozzz

vozzz

    Eats, sleeps, drinks MoGraph

  • Members
  • 1,785 posts
  • Gender:Male
  • Location:New York, NY
  • Interests:In Budapest Hungary

Posted 10 February 2012 - 12:09 PM

for individual objects its not really an issue i just use a spring constraint with 2 nulls, or hand animate it.

i was just hoping i could do this stuff for like a very large number of objects.

-Aleksey

 

------------------

Ace5 studios
http://ace5studios.com <-portfolio

http://ace5education.com <-tutorials/blog/facebook page

 

http://plus.google.c...lekseyVoz/posts <- google+ page


#6 iline

iline

    MoGraph Demi-god

  • Members
  • 683 posts
  • Gender:Male
  • Location:London, UK

Posted 16 February 2012 - 07:50 PM

The Mograph Sample node reads from Effectors. Drop in the effector into xpresso, hook it up to Mograph Sample with the Object port. This outputs a bunch of stuff, but 'Strength' is pretty useful for modulating properties outside of Mograph, through a range mapper no doubt

#7 JMRicks

JMRicks

    MoGraph Regular

  • Members
  • 79 posts
  • Gender:Male
  • Location:Austin, TX

Posted 16 February 2012 - 11:06 PM

From the comments on this post by Tim Clapham:

you need to use something animated to give the delay effector something to process. You could simply animate a null and plug the global matrix of this into the sample effector node. Then output the value and convert it an appropriate value.

See this example file to understand what I’m talking about..

http://www.luxx.com....s/delaybend.zip


Posted Image


Not sure if that really helps with your problem, but I thought it might be somewhat useful.

Edited by JMRicks, 16 February 2012 - 11:15 PM.


#8 vozzz

vozzz

    Eats, sleeps, drinks MoGraph

  • Members
  • 1,785 posts
  • Gender:Male
  • Location:New York, NY
  • Interests:In Budapest Hungary

Posted 17 February 2012 - 11:10 AM

but will that work for an array?

sorry im a bit hung over right now. Like if i have a move effector ( with no delay) and the bend deformer with delay. And then like 500 of them. With random weight and a falloff affecting when they land?

this just seems like a solution for a single object.

edit: i do dig that global matrix null feed though. Remember was working with sound effector and had to keep them at 0,0,0 in the world for them to not screw up.

Edited by vozzz, 17 February 2012 - 11:11 AM.

-Aleksey

 

------------------

Ace5 studios
http://ace5studios.com <-portfolio

http://ace5education.com <-tutorials/blog/facebook page

 

http://plus.google.c...lekseyVoz/posts <- google+ page


#9 JMRicks

JMRicks

    MoGraph Regular

  • Members
  • 79 posts
  • Gender:Male
  • Location:Austin, TX

Posted 18 February 2012 - 03:40 AM

Yeah... that example is just for one object with a bend deformer on it. I doubt that really helps you out. I'm not that good at Xpresso yet, but I thought maybe something in that setup might push you in the right direction. I do wish the delay effector would work in the way you're trying to get it to, though. Seems really useful.

#10 vozzz

vozzz

    Eats, sleeps, drinks MoGraph

  • Members
  • 1,785 posts
  • Gender:Male
  • Location:New York, NY
  • Interests:In Budapest Hungary

Posted 18 February 2012 - 11:23 PM

its not even the bend that should work, its the modify clone parameter that should work, but it doeasnt for some reason

-Aleksey

 

------------------

Ace5 studios
http://ace5studios.com <-portfolio

http://ace5education.com <-tutorials/blog/facebook page

 

http://plus.google.c...lekseyVoz/posts <- google+ page





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users