Jump to content


Photo

Area Shadows looking ugly on close geometry (Cinema 4D)


  • Please log in to reply
10 replies to this topic

#1 illd

illd

    Newbie

  • Members
  • 17 posts

Posted 20 April 2012 - 10:13 PM

Hi Forum,

I wish there was a way to upload scenefiles or screenshots here - I was searching for about 30 min...so I have to explain my issue:

When using Area shadows in Cinema 4D they are looking really ugly (aliased?) on geometry that is close to intersect (like pages on a book). It seems this effect is dependent on the angle of the camera. I tried Increasing antialiasing,shadow samples and shadow accuracy neither didn´t help on the Area shadows.

By using Shadow maps it is looking better, but is far from perfect. Is there a workaround?

Here is a Picture and the scenfile:

http://dl.dropbox.co...Area Shadow.jpg
http://dl.dropbox.co...Problem.c4d.zip

Edited by illd, 21 April 2012 - 06:39 PM.


#2 Crasto

Crasto

    Newbie

  • Members
  • 21 posts
  • Gender:Male
  • Location:Manchester

Posted 20 April 2012 - 10:48 PM

Are they grainy/noisey? I had this problem recently overcome it by changing Ray Depth and Shadow Depth from 15 to 6 and the ShadowMin Samples to 15 and Max Samples 75, Accuracy 100, Transparency Checked.

#3 Mylenium

Mylenium

    Mograph Deity

  • Members
  • 1,485 posts
  • Location:Leipzig, Germany
  • Interests:cycling, music, Sci-Fi

Posted 21 April 2012 - 07:18 AM

Increase the samples on the lights, not in the general rendering settings.

Mylenium
[Pour Mylène, ange sur terre]
----------------------------------------------
www.myleniumblog.com

#4 vozzz

vozzz

    Eats, sleeps, drinks MoGraph

  • Members
  • 1,774 posts
  • Gender:Male
  • Location:New York, NY
  • Interests:In Budapest Hungary

Posted 21 April 2012 - 08:22 AM

you can host images on imgur.com and then link them to here.

-Aleksey

 

------------------

Ace5 studios
http://ace5studios.com <-portfolio

http://ace5education.com <-tutorials/blog/facebook page

 

http://plus.google.c...lekseyVoz/posts <- google+ page


#5 illd

illd

    Newbie

  • Members
  • 17 posts

Posted 21 April 2012 - 03:10 PM

Are they grainy/noisey? I had this problem recently overcome it by changing Ray Depth and Shadow Depth from 15 to 6 and the ShadowMin Samples to 15 and Max Samples 75, Accuracy 100, Transparency Checked.


Damn - it didnt help. No difference at all...

Increase the samples on the lights, not in the general rendering settings.

Mylenium

I doubled it form 40 to 80 samples - no visual difference.


As a workaround I excluded the Pages from the area shadows and relight them instead with a little GI. It s not perfect but so I can keep those nicer area shadows for the environment and the pages are now lit with a soft gi.
It seems the only solution right now...

#6 Mylenium

Mylenium

    Mograph Deity

  • Members
  • 1,485 posts
  • Location:Leipzig, Germany
  • Interests:cycling, music, Sci-Fi

Posted 21 April 2012 - 05:15 PM

Have you experimented with the ray threshold in teh render settings' options section?

Mylenium
[Pour Mylène, ange sur terre]
----------------------------------------------
www.myleniumblog.com

#7 illd

illd

    Newbie

  • Members
  • 17 posts

Posted 21 April 2012 - 05:52 PM

Have you experimented with the ray threshold in teh render settings' options section?

Mylenium

Good Idea - but it made no difference if I had choosen 0,50 or 100 percent.
If I set the shadowdepth to 0 the bad effect is gonne - but at 1it is fully back.

#8 illd

illd

    Newbie

  • Members
  • 17 posts

Posted 21 April 2012 - 06:40 PM

I just uploaded a picture describing the Problem and a scenfile:


http://dl.dropbox.co...Area Shadow.jpg
http://dl.dropbox.co...Problem.c4d.zip

#9 tarzan_jesus

tarzan_jesus

    MoGraph Regular

  • Members
  • 88 posts
  • Gender:Male
  • Location:montreal - canada

Posted 24 April 2012 - 02:37 PM

You sir, have an anti-aliasing problem.
When ever you have thin strips of high contrast that start stepping and blending together this should be the first place to look.

bump up the min level to :2x2
and the max level to: 8x8
and then lower the threshold to around 2.5 - 5%

Prepare for longer render times.
I went from 1:23 to 2:24
Now as a proper sell, dropping the exact same scene into the physical renderer produces a render time of 0:08

One thing you may want to do is ditch sinc as the AA method and choose a filter that is faster / has less sharpening...unless it is really needed.

Edited by tarzan_jesus, 24 April 2012 - 02:44 PM.

ARRRRRRrrrrrrrrrooooooooooooooooooooOOOOOOooooOOOOooooo!

#10 illd

illd

    Newbie

  • Members
  • 17 posts

Posted 24 April 2012 - 10:33 PM

You sir, have an anti-aliasing problem.
When ever you have thin strips of high contrast that start stepping and blending together this should be the first place to look.

bump up the min level to :2x2
and the max level to: 8x8
and then lower the threshold to around 2.5 - 5%

Prepare for longer render times.
I went from 1:23 to 2:24
Now as a proper sell, dropping the exact same scene into the physical renderer produces a render time of 0:08

One thing you may want to do is ditch sinc as the AA method and choose a filter that is faster / has less sharpening...unless it is really needed.

Ok - sounds good - I´ll give it a try. To be honest I only tried the AA methods sinc and still frame, but did never touch the threshhold.
Is there a way to force the extra AA only on the problematic layers via a tag or so? I thoiught I saw that some where but maybee I mix it up with the motionblur tag...

#11 destro

destro

    Mograph Deity

  • Members
  • 946 posts
  • Gender:Male

Posted 25 April 2012 - 02:45 AM

Ok - sounds good - I´ll give it a try. To be honest I only tried the AA methods sinc and still frame, but did never touch the threshhold.
Is there a way to force the extra AA only on the problematic layers via a tag or so? I thoiught I saw that some where but maybee I mix it up with the motionblur tag...


It's an option in the compositing tag.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users