Jump to content


Photo

Frischluft Depth of Field render issues

Black squares

  • Please log in to reply
9 replies to this topic

#1 theta

theta

    MoGraph Demi-god

  • Members
  • 454 posts
  • Gender:Male
  • Interests:v1 getting approved!

Posted 30 November 2012 - 04:44 PM

Has anyone experienced this problem? I have a few layers in AE with the DoF plugin on them. And I'm getting big black boxes on random frames, like it's having trouble rendering parts of the image. If I adjust the radius slightly, it sometimes fixes it, but it's really inconsistent between frames so it might not render another frame correctly.

#2 Todd Kopriva

Todd Kopriva

    Adobe Mastermind

  • Members
  • 785 posts
  • Gender:Male
  • Location:Seattle, WA, USA

Posted 30 November 2012 - 05:01 PM

What versions of After Effects and the Frischluft plug-in?

Have you installed the latest updates (http://adobe.ly/lsrkmJ)?

Edited by Todd Kopriva, 30 November 2012 - 05:01 PM.

---------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
After Effects product manager and curmudgeon
After Effects team blog
---------------------------------------------------------------------------------------


#3 theta

theta

    MoGraph Demi-god

  • Members
  • 454 posts
  • Gender:Male
  • Interests:v1 getting approved!

Posted 30 November 2012 - 05:03 PM

AE CS6 (11.0.1.12)

Frischluft v1.4.6


I think there is an update to CS6 that I haven't installed yet.

#4 theta

theta

    MoGraph Demi-god

  • Members
  • 454 posts
  • Gender:Male
  • Interests:v1 getting approved!

Posted 30 November 2012 - 05:22 PM

Well, just updated to CS6 11.0.2 and Lenscare 1.4.7 and am still getting the same thing. I should probably point out too, that it works fine if the plugin is applied to one, even two layers. But the artifacts happen when I start adding the effects to multiple layers. I might have to just pre-render some of this stuff, hmm...EDIT: Also, seems to happen when I have an adjustment layer turned on with some Sapphire plugins, so who knows what is to blame. I guess it's time to pre-render some stuff :(

Edited by theta, 30 November 2012 - 05:32 PM.


#5 monovich

monovich

    Mograph Deity

  • Members
  • 879 posts
  • Gender:Male
  • Location:Colo-rad-o
  • Interests:shiny things, shiny graphics, shiny bikes

Posted 30 November 2012 - 06:04 PM

I've seen that problem myself but don't know how to fix it.
I'm not sure how you are creating your depth buffer but the plugin seems sensitive to the "quality" of them. Usually if I leave my depth channel alone things work fine, but when I clamp values or otherwise mess with it things go south.

Have you tried adjusting any min/max depth values in your 3d renderer? That might help.

#6 theta

theta

    MoGraph Demi-god

  • Members
  • 454 posts
  • Gender:Male
  • Interests:v1 getting approved!

Posted 30 November 2012 - 06:42 PM

The depth buffer is being created in AE via Sapphire_Grad, so for these specifc layers, I'm kinda just faking it. But there's no additional effects on top of that grad effect. If I adjust any of the grad parameters, the same thing happens, it may fix it for some frames, but not all of them. Weird.

For now,I'm just rendering the whole sequence with this adjustment layer with Sapphire plugins turned off, which renders the DoF fine. Then re-importing the rendered sequence and adding that adjustment layer back on top and rendering that. It's an extra step, but at least it works.

#7 microdot

microdot

    MoGraph Demi-god

  • Members
  • 457 posts
  • Gender:Male
  • Location:Brooklyn

Posted 12 December 2012 - 01:36 AM

Sorry this is slightly OT, but I was wondering what most people have been doing to remedy the 'dirty edges' that sometimes occur with frischluft. Love the dof plug but this drives me crazy.

I had heard it was something to do with c4d depth passes being anti aliased so i started rendering a sep RLA pass and using channel extract as the source for frisch and this worked well, but its a bit of an annoying workflow, esp using netrender.

Anyone else have a good technique? (Besides a preChoke)

Thanks

M


#8 Aaron Scott

Aaron Scott

    MoGraph Demi-god

  • Members
  • 549 posts
  • Gender:Male
  • Location:Vancouver

Posted 12 December 2012 - 05:51 PM

I'd love to hear some thoughts on this, too. For some reason depth maps out of Cinema have always been a headache for me, requiring a bunch of manual tweaking and blurring in problem areas.



#9 Sen

Sen

    Newbie

  • Members
  • 21 posts
  • Gender:Male

Posted 13 December 2012 - 11:11 AM

Yeah, it's quite a difficult problem to solve.

 

If you anti-alias your Z-depth pass, any anti-aliased pixels would indicate wrong depth values and result in artefacts. In case of aliased Z-depth pass and anti-aliasing on the image, the passes don't align exactly which result in another type of edge artefacts. You can deal with the second problem by rendering your aliased Z-depth pass at double resolution. Add the oversized Z-depth pass and the image pass (scaled at 200%) in a pre-comp. Apply Lenscare and then scale the pre-comp back to 100% in another comp. You'll notice that Frischluft is really slowing down because of the oversized comp… :-) If you're still seeing some edge artefacts you can try applying the minimax effect (operation: maximum, radius: 1px) on the Z-depth pass.

 

In case of obscuration artefacts, you need to render in layers (FG, BG) and blur separately because you want the pixel information behind FG objects.

 

Deep compositing data (Open EXR 2.0) is the ultimate solution, but it's going to take a while to arrive in AE and C4D, I suppose. 

http://www.deepimg.com/


Edited by Sen, 13 December 2012 - 01:44 PM.


#10 Aaron Scott

Aaron Scott

    MoGraph Demi-god

  • Members
  • 549 posts
  • Gender:Male
  • Location:Vancouver

Posted 13 December 2012 - 06:59 PM

This has been my fix. It works, but it's messy.

 
I have an image with an object buffer for the foreground. Using that, I create a number of precomps:
 
- foreground only
- background only
- foreground depth
- background depth
 
When you only have a single depth pass for the entire scene, you can't simply knock out the foreground or background then use minimax to dilate it out a bit (to cover any aliased pixels), since minimax will start grabbing colours from the pixels that have zero alpha. I haven't found a reasonable way around this. So instead, I duplicate the depth comp, blur it slightly, crunch the alpha, and place the blurred depth map under the clean one. The result is almost exactly the same as a proper dilate. Unfortunately, this doesn't always result in a clean depth of field -- sometimes the anti-aliasing has trouble in the opposite direction, so the depth of field has to be slightly choked before it's dilated. My final setup ends up looking like this:
 
null
--> sliders to control depth of field
 
foreground only
--> frischluft (using "foreground depth map comped")
 
background only
--> frischluft (using "background depth map comped")
 
foreground depth map comped
foreground depth map
--> simple choker (a few pixels, optional)
foreground depth map
--> simple choker (a few pixels, optional)
--> fast blur (a few pixels)
--> levels (crunching the alpha)
 
background depth map comped
background depth map
--> simple choker (a few pixels, optional)
background depth map
--> simple choker (a few pixels, optional)
--> fast blur (a few pixels)
--> levels (crunching the alpha)

 

If anyone has a better solution than this, I'd love to hear it.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users