Jump to content
Sign in to follow this  
Yates Holley

Fail

Recommended Posts

Have been getting this error a bit today

 

After Effects error: cannot insert an item into a locked list

(27::38)

 

I get the error when i try to add anything to an existing comp i have. I cant copy paste into it i cant create new layers within it.

 

Something i have found that has fixed it is removing a certain comp out of my scene. but i dont see how a comp within a comp effects its parent comp. (mind you nothing is locked within that comp either)

 

In case anyone jumps on the word LOCKED in the topic - no layers are locked, no masks are locked, no effects are locked.

 

anyone have any idea where this error is coming from? About to copy everything into a new comp to circumvent the problem, but would like to know if anyone has any idea what this problem is so i can avoid it in the future.

 

the comp is an hour long (dont ask). not sure if that makes a difference.

Edited by Yates Holley

Share this post


Link to post
Share on other sites

Yes! I have had this problem as well.

I just created a new comp and copied and pasted all i needed into that..I have no idea what a "locked list" is, so anyone who knows I would really like to hear!

Share this post


Link to post
Share on other sites

i'm guessing here, but a "locked list" sounds to me like an array that for whatever reason is designated read-only. when you add something to your comp it's trying to write to that array but can't and hence errors... but that's only a guess.

Share this post


Link to post
Share on other sites

I've been having a similar problem lately, mine says something like "cannot place in a read only list" or something like that. Happens at complete random times in any comp and any project. I just restart AE and it works fine. No idea whats going on.

Share this post


Link to post
Share on other sites
Guest Sao_bento

Could everyone who's had this problem list your CPU manufacturer and OS version, etc.?

 

 

Thanks.

Share this post


Link to post
Share on other sites

Yes! I have had this problem as well.

I just created a new comp and copied and pasted all i needed into that..I have no idea what a "locked list" is, so anyone who knows I would really like to hear!

 

Locked list refers to the internal item collections used by AE. Under certain circumstances it can happen that AE assigns the same internal ID to different items which causes an unresolvable paradox and effectivley "locks" those lists. Usually a restart wil lfix this. If it still doesn't, try to import your existing project into a new empty project. This will force AE to assign new IDs to all project items.

 

Mylenium

Share this post


Link to post
Share on other sites

I've had this happen a few times, but only in AE6.5. Nothing a restart hasn't fixed. The image buffer/memory

issue has been more of a hassle lately...and evidently not just for me.

 

(p4 3.0HT XP, Dell)

Share this post


Link to post
Share on other sites
Getting this occasionally on CS4. Save, quit, run, open fixes it.

Just for the record.

 

9.0.2.42, Mac OS X 10.5.7.

 

Hmm. Mylenium's reply above isn't completely accurate. Internally AE will lock a list (this can be the list of layers, or items in the project, or render queue items, they are all over the place), add or remove an item, and then unlock the list. A error of this sort (unable to insert to locked list) means that a lock was unbalanced. The most common reason is that an error occured and the error recovery code had a bug in it.

 

So if you get this message, try and remember the last couple of things that you did, especially any kind of message dialog that might have appeared. If you want to help us solve this, please drop a line to aebugs@adobe.com with the following info:

1) The previous few things you were doing including any error messages.

2) If you can reproduce it or now.

3) The action you are trying to do that causes it.

4) The version of the application you are running.

 

If you aren't willing to gather that info, please don't bother sending something into aebugs. This error message isn't specific enough for us to do anything with without the additional context.

 

--chris

Share this post


Link to post
Share on other sites

I'll try and take note next time, mines seems to happen after my ram preview lengths start dropping, having to purge memory a lot more than cs3 to get that up a bit, I just presumed it was a low memory error, this is on my mbp with only 2gb. OSX10.5.7 by the way...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...