Jump to content
Sign in to follow this  
alex

composition footage freezing

Recommended Posts

hi everyone

 

got a real problem, ive got some greenscreen footage

layed over some background graphics except now and again

my greenscreen footage freezes and stops moving??!!

its doing it in all my comps

 

the only way i can correct it is by either restarting af

or purging the ram.

 

does anybody have any ideas as to resolve this problem

 

cheers

Share this post


Link to post
Share on other sites
Guest dumbo

sounds like you don't have enough ram, as the problem is fixing by freeing up ram. how much do you have on your system? pc or mac? graphics card? etc

Share this post


Link to post
Share on other sites

im using a macbook pro 2.33 core 2 duo with 2 gigs of ram, normal macbook pro gfx card

i use this for when im working from home.

 

my memory and cache setting are

 

max mem usage 120% = 2.4 gb

max ram cache size 65% = 1.3gb

 

its strange because its only started to

do this and have been using this laptop

for ages

Share this post


Link to post
Share on other sites

Sounds like a CoDec problem. Certain QT CoDecs have been known to show this odd behavior once you add Alpha by keying. In these cases MediaCore is not properly refreshing the output because the keyer isn't requesting it after a certain point. Seems to be a bug.

 

Mylenium

Share this post


Link to post
Share on other sites

Does just the greenscreen freeze or does everything freeze?

 

Interesting problem. What QT codec do you use? If I were you, I'd try (as a test) to re-render the greenscreen footage asset to a different codec or a TIFF seq or AVI or something else, then replace the footage w/ this re-rendered asset and see if the freezing continues. If so that should isolate the problem to your codec. I don't know if adding more ram would fix this, maybe but if it's just the greenscreen footage and nothing else then it seems more like a problem w/ AE reading the file itself.

 

Maybe if you fiddle around w/ some of the AE secret settings? g'luck

Share this post


Link to post
Share on other sites

the original footage was loaded into final cut and

came out as aja 625 8 bit i believe but this normal

anyway so dont think the problem is there.

 

its both the rendered greenscreen footage and the

rendered backgrounds that either freeze

 

it looks like its either a ram issue or after effects

reading the files.

 

Could it be a bug within my after effects?

Share this post


Link to post
Share on other sites

Is this during Make Movie or Previews? Are there any problems with setting AE to automatically purge every couple of frames during Make Movie? Maybe you can disable OpenGL/enable it? see if the problem lies with that (if it's during previews).

Share this post


Link to post
Share on other sites
Could it be a bug within my after effects?

 

Me no think so. Even MediaCore still invokes standard QT components which probably is the issue here. From my personal experience I only had these issues with deep color CoDecs (Cineform) that are piped thru MediaCore while using Keylight on them, but you never know. Anyway, I would try disabling hardware acceleration on all ends where possible. As already mentioned, turn off OpenGL in AE. As a second step, check your QT settings. If it's outputs have been rerouted to your video hardware, set it back to the default system outputs - sounds unrelated, but might be an issue. In addition, check your CoDecs. I'm also reasonably sure that using hardware CoDecs provides some option to use GPU acceleration in the CoDec's settings somewhere. Similarly to the rest, turn it off when working in non-accelerated apps like AE. As an last step, you may want to remove any unnecessary CoDecs (temporarily). If you never use ProRes, nothing's lost by removing the component and putting it into a safe place. The same for the others.

 

Mylenium

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...