Jump to content
Sign in to follow this  
kitkats

After Effects / Mac Pro Performance issues

Recommended Posts

For the last year or so I've been working mainly on a Macbook Pro, with 4 gigs of RAM, a Core 2 Duo 2.5ghz and a SSD. Sometimes it does crawl a bit and I've been waiting for some new Mac Pro's to come out to get one. For the current job though, I hired a Mac Pro. 2 x Quad 2.26ghz, 16GB Ram otherwise standard config - the rental place got it new in form apple for me. I've allocated 2.09GB of RAM per cpu so it's using 6 background cpu's in total. Using AE CS4.

 

Thing is, the performance of this thing is just so much worse than I was expecting. Of course it renders and RAM Previews faster than my laptop once it gets going, but I seem to be waiting more than ever before. Just now I hit Caps Lock to move some layers around in the timeline and every time I touched a layer I got a spinning beachball - it happened about 6 times all with a black comp window. It seems crazy that such an expensive machine is so sluggish...There seems to be a huge overhead just linking up between the main app and all the aeselflink background processes, but even with multiprocessing turned off the feel of the GUI is so unresponsive.

 

Is this simply what it's like? Is CS5 a massive improvement in this area? Would a high-spec GPU help much? I'm thinking ahead to when new Mac Pro's appear and wondering if I'd be best to just get a lower end model (with faster but fewer cores).

Share this post


Link to post
Share on other sites

I just upgraded to same Macpro you hired and I am not experiencing these issues, maybe not as blazingly fast as I would hope for some things, but no beach balls or anything like that, ram previews and audio previews start right away. I've had the problem of waiting on ram preview starts before and really slugish interface on projects with lots of layers (regardless of machine). I've found usually disabling thumbnails in the project panel helps. Worst case splitting things into multiple comps, projects. Hard to tell if this is your issue or not but yeah something is up with your setup shouldn't be that sluggish.

Share this post


Link to post
Share on other sites

One of the big improvements in After Effects CS5 is that the background processes used for Render Multiple Frames Simultaneously multiprocessing start up much faster. Like, so fast that I can't even read the message that says that they're starting.

 

Of course, your mileage may vary, and you won't believe me anyway since I'm the Adobe guy. ;)

 

One thing that really, really helps performance is to make sure that you're leaving a processor or two and a couple of GB of RAM free for other software. The biggest performance killer is swapping memory from RAM to disk, which is what happens when you don't leave some RAM for other applications. In After Effects CS5, we enforced that by not allowing you to set the value lower than a certain fraction of your RAM.

 

Some stuff here might help:

http://forums.adobe.com/thread/543440

Share this post


Link to post
Share on other sites

I was running into this same problem, yesterday. Here I am on a Mac with 16 cores and 32GB and I am looking at a beach ball spinning while AE tries to preview two layers. I get much better performance out of AE on my Dual Windows XP laptop with 3BG.

 

Sometimes I just don't get it. But the delay does seem to be related directly to what you are scrubbing. The more efficient your layers are, the quicker the performance. Setting up proxies can be a pain, but they certainly help out in heavy scenes. Don't just dump those 10Mega pixel images into your comp. Also try to avoid super large sub-comp sizes.

Share this post


Link to post
Share on other sites

Well, today I have a comp with 4 precomps - all full of many, many (probably over a thousand in total) other layers. But - ALL these 4 precomps are turned OFF. Then I have one audio layer. I hit period. Wait, wait... Literally 4 or 5 minutes later the audio plays.

 

I cannot see how that is the fault of the way I've set up this machine. Surely the software should see that there is no video to render and just get on and play the audio? I don't expect NLE type performance, but Jeez....

 

Edit: The crazy thing is that this problem is far worse on the Mac Pro 6GB RAM (Multiprocessing turned OFF) than on my Macbook Pro 4GB RAM (also turned OFF)!!

Edited by kitkats

Share this post


Link to post
Share on other sites

Is OpenGL turned on? I have a Mac Pro one or two generations back and I don't experience any of those problems. Even with my current project with hundreds of layers I can preview decently at all resolutions, though I usually work at half. I definitely don't experience waiting that long for an audio preview. Maybe try reinstalling the software?

Share this post


Link to post
Share on other sites

Is OpenGL turned on? I have a Mac Pro one or two generations back and I don't experience any of those problems. Even with my current project with hundreds of layers I can preview decently at all resolutions, though I usually work at half. I definitely don't experience waiting that long for an audio preview. Maybe try reinstalling the software?

 

Yeah, I'd try a reinstall. I had a persistent problem in AE CS4 with RAM previews disappearing that was corrected (although only temporarily) with a reinstall.

 

AE CS5 definitely helps with all the performance issues. Unfortunately it's still more of a utility for me rather than my main app since there are still many plugins that have not been updated for CS5, and I have a lot of older projects that I have to go back into fairly often that use these plugs (the curse of third party plugins).

Share this post


Link to post
Share on other sites

Tried re-installing (I had used Migration Assistant, so figured that may have screwed settings up somehow) to no avail. I then read this which suggested it may have something to do with the sheer number of files in this project (only 3 or 4 hundred TIFF's - no bigger than 800x500). I was already using these images in precomps and accessing them via time remapping to apply some common effects to all of them at once, so I rendered out these 'image sequences' as QT's and reimported, essentially just massively reducing the number of files. This helped a lot.

 

But, there are still far more little 5-10 second delays (usually spinning beachball) on the Mac Pro. Some examples of when they occur (In all these cases my laptop begins the requested action almost immediately, whereas the MacPro delays):

 

I hit zero to RAM preview

I've just hit RAM preview, but then change my mind and click on the timeline somewhere to jump to that frame instead.

I've RAM previewed and all necessary frames are cached and green and I've stopped the playback with zero key. I hit zero again to watch the RAM preview again.

I hit period to Audio Preview

 

 

Other (non beachball) problems:

I've dragged a keyframe on a layer which is turned off and it feels sticky and won't move along the timeline smoothly, as if AE was trying to apply the changes to the (admittedly complex) comp. The yellow preview-render bar doesn't move and the current frame stays rendered and green, but the keyframe itself appears to not move and then jumps suddenly, making it difficult to place where I want it.

 

I've long since stopped using multi-processing on either machine, even when rendering as the Mac Pro's renders were slowing to a halt for no apparent reason. Oddly, when I went into Activity Monitor and force quit the two (yes, two - I only have 6GB of RAM in it) 'aerender' processes, it started up again. I'll say it again - the Mac Pro still renders faster and with RAM previews longer than a second will preview faster. But all the beachball action is making it really horrible to work on. Today I'm working from home on my laptop and it feels so much easier. I do have an SSD in this laptop...but the MP still seems weird.

 

I just hope by the time I get CS5 (or CS5.5 - anyone else hear about that?) and my own next-gen Mac Pro, this doesn't happen. I can actually deal with render times, its the responsive interface that I was mainly hoping to get with a new machine.

Share this post


Link to post
Share on other sites
(or CS5.5 - anyone else hear about that?)

 

blink.gif No, I haven't... already? Show us the goods. All I can find is this

 

 

 

I would probably turn off multiprocessing if I were in your shoes. Its not like it will disregard all of your cores, it will just use them all at once on a frame by frame basis. Also try turning off the audio for all of your precomps, mix the audio outside of AE and bring it back in as a single layer in the main timeline. I have had similar experiences but quickly assumed (my own diagnosis) AE doesn't like mixing audio deep within different subcomps.

Edited by AromaKat

Share this post


Link to post
Share on other sites

blink.gif No, I haven't... already? Show us the goods

 

I've seen the rumor that KitKats is referring to, and I recommend not trusting announcements of features and future versions that don't come from Adobe.

Share this post


Link to post
Share on other sites

I would probably turn off multiprocessing if I were in your shoes. Its not like it will disregard all of your cores, it will just use them all at once on a frame by frame basis. Also try turning off the audio for all of your precomps, mix the audio outside of AE and bring it back in as a single layer in the main timeline. I have had similar experiences but quickly assumed (my own diagnosis) AE doesn't like mixing audio deep within different subcomps.

Thanks, but like I said, I've long since kept MultiProcessing off. This project is only using one layer of audio in the Master comp. I always turn off any precomp audio too.

Share this post


Link to post
Share on other sites

Thanks, but like I said, I've long since kept MultiProcessing off. This project is only using one layer of audio in the Master comp. I always turn off any precomp audio too.

 

Where is your footage stored? A while back I had an external RAID start to fail, and for a few days before it completely died I was getting horrible hangs in After Effects. If you can conveniently move your footage to another drive and try the project again, this will at least eliminate the possibility of a failing drive.

 

I might also try to export copies of your footage files into different formats. I've found that AE CS4 can be unhappy with EPS files and pretty much anything in CMYK instead of RGB.

Share this post


Link to post
Share on other sites

Footage always on the internal bootup drive. No CMYK, no EPS - I never use either in AE unless by accident. I've tried this on two different, brand new Mac Pro's so it isn't machine specific although it may have been a little worse on the second one. When I get back to the Mac Pro I might try going back to Leopard (am on 10.6.3) and see if that helps. My guess at the moment is that it could be that, plus too little RAM (6GB isn't enough really) possibly in a crappy configuration (it came straight from Apple).

Share this post


Link to post
Share on other sites

I've always had slight delays with some of the things you described after re-installing. I'm on a 2008 Mac Pro Octo w/ 18GB of RAM on CS3 with 10.5.8. It's annoying as hell and has pretty much become part of the daily routine. It may not be as bad as you're describing, but definitely a noticeable delay with or without multiprocessing. I'm hoping that CS5 cleans some of that up, but I'm waiting to upgrade until they get the kinks worked out of Photoshop and Illustrator, which I own. Makes me hesitant to grab CS5.

 

I've never had the dragging keyframe problem though.

Share this post


Link to post
Share on other sites

That's worth knowing, thanks. I had a feeling it might be specific to the 2009 Mac Pro's as I don't remember it happening quite so badly on the 2008's but it was a long tie ago I worked on one of those, I think. When new Mac Pro's come out I'll maybe wait awhile and see what reports they get, then try the trial of CS5 on one. I have been distantly considering switching to Windows but I'd probably want to trial that on bootcamp first too.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...